plainblack.com
Username Password
search
Bookmark and Share
Subscribe

Installing WebGUI on Debian

Using WRE

Install following Debian Packages before build WRE:

  • libreadline5-dev
  • libaspell-dev
  • zlib1g-dev

Example:
apt-get install libreadline5-dev libaspell-dev zlib1g-dev

Without WRE

Install mysql-server

Install following Debian Perl Packages

libtest-deep-perl
libtest-mockobject-perl
libpod-coverage-perl
libdbi-perl
libdbd-mysql-perl
libarchive-tar-wrapper-perl
libarchive-zip-perl
libmime-tools-perl
libtie-ixhash-perl
libtie-cphash-perl
libxml-simple-perl
libsoap-lite-perl
libdatetime-perl
libdatetime-format-strptime-perl
perlmagick
liblog-log4perl-perl
libnet-ldap-perl
libhtml-highlight-perl
libhtml-template-perl
libhtml-template-expr-perl
libparse-plainconfig-perl
libxml-rsslite-perl
libjson-perl
libnet-subnets-perl
libfinance-quote-perl
libpoe-perl
libpoe-component-client-http-perl
libdata-structure-util-perl
libcache-memcached-perl
libtext-aspell-perl
libweather-com-perl
libapache2-request-perl 

libnet-dns-perl
libdatetime-format-mail-perl
libdatetime-format-http-perl
libhtml-tagfilter-perl
libxml-feedpp-perl
libxml-feedpp-mediarss-perl
libconfig-json-perl
libtext-csv-xs-perl
libnet-cidr-lite-perl
libpoe-component-ikc-perl
libcolor-calc-perl
libclass-insideout-perl
libhtml-tagcloud-perl
libimage-exiftool-perl
libarchive-any-perl
libpath-class-perl
libexception-class-perl
libclone-perl
libjavascript-packer-perl
libcss-packer-perl
libhtml-packer-perl
libbusiness-tax-vat-validation-perl
libscope-guard-perl
libcss-minifier-xs-perl
libjavascript-minifier-xs-perl
libreadonly-perl
libbusiness-paypal-api-perl
libbusiness-onlinepayment-viaklix-perl
libbusiness-onlinepayment-authorizenet-perl
liblocales-perl
libdatetime-event-ical-perl
libcache-fastmmap-perl
libtest-tester-perl
libtest-log-dispatch-perl
libchi-perl
libperlio-eol-perl
libmonkey-patch-perl (needed for non-WRE install?)
libkwargs-perl
libdata-ical-perl
libgeo-coder-googlev3-perl
libtemplate-perl (optional)
libnet-twitter-perl (*)


* Note: libnet-twitter-perl is only available in unstable (sid) and not in stable (wheezy) now (April 1st 2014). On my system, I've put a pinning on stable (wheezy) of 1001, and on unstable (sid) of 100. This means that the system will even downgrade a package to get it from stable if it can get a package from both stable and unstable (this happens with a pin above 1000). In general this is not advisable and you better use a pin-value below 1000.

I've installed the package with:

# apt-get install libnet-twitter-perl/unstable
This will take all dependencies from stable if it can. (it can) If it couldn't you could have it instaled with:

# apt-get -t unstable libnet-twitter-perl


To install all modules at once:

# apt-get install libtest-deep-perl libtest-mockobject-perl libpod-coverage-perl libdbi-perl libdbd-mysql-perl libarchive-tar-wrapper-perl libarchive-zip-perl libmime-tools-perl libtie-ixhash-perl libtie-cphash-perl libxml-simple-perl libsoap-lite-perl libdatetime-perl libdatetime-format-strptime-perl perlmagick liblog-log4perl-perl libnet-ldap-perl libhtml-highlight-perl libhtml-template-perl libhtml-template-expr-perl libparse-plainconfig-perl libxml-rsslite-perl libjson-perl libnet-subnets-perl libfinance-quote-perl libpoe-perl libpoe-component-client-http-perl libdata-structure-util-perl libcache-memcached-perl libtext-aspell-perl libweather-com-perl libapache2-request-perl   libnet-dns-perl libdatetime-format-mail-perl libdatetime-format-http-perl libhtml-tagfilter-perl libxml-feedpp-perl libxml-feedpp-mediarss-perl libconfig-json-perl libtext-csv-xs-perl libnet-cidr-lite-perl libpoe-component-ikc-perl libcolor-calc-perl libclass-insideout-perl libhtml-tagcloud-perl libimage-exiftool-perl libarchive-any-perl libpath-class-perl libexception-class-perl libclone-perl libjavascript-packer-perl libcss-packer-perl libhtml-packer-perl libbusiness-tax-vat-validation-perl libscope-guard-perl libcss-minifier-xs-perl libjavascript-minifier-xs-perl libreadonly-perl libbusiness-paypal-api-perl libbusiness-onlinepayment-viaklix-perl libbusiness-onlinepayment-authorizenet-perl liblocales-perl libdatetime-event-ical-perl libcache-fastmmap-perl libtest-tester-perl libtest-log-dispatch-perl libchi-perl libperlio-eol-perl libmonkey-patch-perl libkwargs-perl libdata-ical-perl libgeo-coder-googlev3-perl libtemplate-perl libnet-twitter-perl

Keywords: debian Installation packes

Search | Most Popular | Recent Changes | Wiki Home
© 2017 Plain Black Corporation | All Rights Reserved