plainblack.com
Username Password
search
Bookmark and Share

    

WRE on Centos 5.5 32bit?

User jmack
Date 1/14/2011 10:08 am
Views 8119
Rating 8    Rate [
|
]
Previous · Next
User Message
jmack

Does anyone get WRE 0.9.3 get to work on Centos 5.5 32bit?
I'm stuck in 7.8.24. There is no way I get the needed perl-modules for 7.9.x installed. 

Not via:
- testEnvironment update script
- Cpan force install etc.

--- (Edited on 1/14/2011 10:08 am [GMT-0600] by jmack) ---



Back to Top
Rate [
|
]
 
 
perlDreamer

Which modules are you having problems installing?

--- (Edited on 1/14/2011 12:06 pm [GMT-0800] by perlDreamer) ---



Back to Top
Rate [
|
]
 
 
jmack

Anyway these are problematic, CHI, Cache::FastMmap and Moose related modules.

Are these kind of issues known around using Centos(/RHEL) 5.5 in general?
(To be able to enumerate exactly ALL I've tried, it might be good to give it a new round.)
Any hints before I start?

- Played with SElinux, switched it off
- All redhat-modules mentioned in the wiki are installed, like CC, libgomp etc.
- used testEnvironment update script
- used ./setEnvironment.pl before I start
- tried Cpan force install CHI and Cache::FastMmap etc.

The WebGUI-server is a KVM virtualised one with 32bit Centos 5.5.
The host is Centos 5.5 64bit (Server: Dell PE XEON)

--- (Edited on 1/17/2011 7:03 pm [GMT-0600] by jmack) ---



Back to Top
Rate [
|
]
 
 
bmccann

Exact same problem to the T.  I'm working through it right now trying to find a solution, hitting brick walls left and right.

 

Only difference is mine is on a dedicated CentOS 5.5 64 bit.  Using the latest WRE.

 

I'm getting, assuming you are to, the "Error: wrong ELF class: ELFCLASS64" while trying to compile the perl modules that are failing.

 

 

#   Failed test 'use Cache::FastMmap;'
#   at t/5.t line 5.
#     Tried to use 'Cache::FastMmap'.
#     Error:  Can't load '/root/.cpan/build/Cache-FastMmap-1.36-GnyCVD/blib/arch/auto/Cache/FastMmap/CImpl/CImpl.so' for module Cache::FastMmap::CImpl: /root/.cpan/build/Cache-FastMmap-1.36-GnyCVD/blib/arch/auto/Cache/FastMmap/CImpl/CImpl.so: wrong ELF class: ELFCLASS64 at /data/wre/prereqs/lib/perl5/5.10.0/i686-linux/DynaLoader.pm line 203.

#   Failed test 'use Cache::FastMmap;'#   at t/5.t line 5.#     Tried to use 'Cache::FastMmap'.#     Error:  Can't load '/root/.cpan/build/Cache-FastMmap-1.36-GnyCVD/blib/arch/auto/Cache/FastMmap/CImpl/CImpl.so' for module Cache::FastMmap::CImpl: /root/.cpan/build/Cache-FastMmap-1.36-GnyCVD/blib/arch/auto/Cache/FastMmap/CImpl/CImpl.so: wrong ELF class: ELFCLASS64 at /data/wre/prereqs/lib/perl5/5.10.0/i686-linux/DynaLoader.pm line 203.

 

--- (Edited on 1/20/2011 11:38 am [GMT-0600] by bmccann) ---

--- (Edited on 1/20/2011 11:45 am [GMT-0600] by bmccann) ---



Back to Top
Rate [
|
]
 
 
preaction

Are you actually on a 64bit arch? The 32bit version we offer does not know how to compile perl modules on 64bit, but here is a /data/wre/prereqs directory that you can use that does understand:

http://dl.dropbox.com/u/226725/wre-latest-prereqs-centos5.5-x64.tar.gz

Just replace your /data/wre/prereqs with the version inside of this archive: tar zxf wre-latest-prereqs-centos5.5-x64.tar.gz -C /data

--- (Edited on 1/20/2011 1:51 pm [GMT-0600] by preaction) ---



Back to Top
Rate [
|
]
 
 
bmccann

Are you actually on a 64bit arch? The 32bit version we offer does not know how to compile perl modules on 64bit, but here is a /data/wre/prereqs directory that you can use that does understand:

http://dl.dropbox.com/u/226725/wre-latest-prereqs-centos5.5-x64.tar.gz

Just replace your /data/wre/prereqs with the version inside of this archive: tar zxf wre-latest-prereqs-centos5.5-x64.tar.gz -C /data

--- (Edited on 1/20/2011 1:51 pm [GMT-0600] by preaction) ---

That worked!  Only thing wrong is after loading the above, we lost the ability to use the WeatherData module Frown.

We tried to compile the WRE into our 64 bit OS, but failed after many attempts and decided to just use the 32 bit, which had worked perfect up until version 7.9.X

--- (Edited on 1/20/2011 3:36 pm [GMT-0600] by bmccann) ---



Back to Top
Rate [
|
]
 
 
johnsonbrad1

I'm having the same issue, but it looks like the download link is no longer valid.  Can you re-upload this?

--- (Edited on 9/2/2011 10:15 am [GMT-0500] by johnsonbrad1) ---



Back to Top
Rate [
|
]
 
 
    



© 2019 Plain Black Corporation | All Rights Reserved