plainblack.com
Username Password
search
Bookmark and Share

    
Goto page «Previous Page   1 2    Next Page»

New site

User bsweb
Date 10/18/2011 3:06 pm
Views 1055
Rating 0    Rate [
|
]
Previous · Next
User Message
bsweb

I am new to WEBGUI and just recently installed it.  I see now that in order to create my own theme, this needs to be done during the site setup. My install was not done with WRE.  I am running on Linux ubuntu.  How can I create a new site?  Or is there a way to go back into the setup to install my own theme?  I'm stuck before I started.

 

--- (Edited on 10/18/2011 3:06 pm [GMT-0500] by bsweb) ---



Back to Top
Rate [
|
]
 
 
perlDreamer

During the site setup, the setup wizard will give you chance to pick from a set of default themes.  You can always install new themes after your site is setup.

There's a full set of instructions in the wiki for doing a source install.

--- (Edited on 10/18/2011 1:51 pm [GMT-0700] by perlDreamer) ---



Back to Top
Rate [
|
]
 
 
bsweb

I already have a site but it doesn't have my theme.  I didn't think I could install a new theme except during a new site setup and I did not know how to get back to that. 

But I can install a new theme even with the site started?

--- (Edited on 10/18/2011 4:04 pm [GMT-0500] by bsweb) ---



Back to Top
Rate [
|
]
 
 
perlDreamer

In WebGUI, a theme is essentially a set of templates and other assets to style the site.  You can create them by hand in the site, or import them as a package to use them on the site.

Then, you would edit any existing assets on your site to use the style template instead of what they are using now.  You can edit many assets all at the same time using the Edit Branch command, which is available in the Asset Manager in the "More" context menu, or by clicking on the class icon in the editing bars.

--- (Edited on 10/18/2011 3:33 pm [GMT-0700] by perlDreamer) ---



Back to Top
Rate [
|
]
 
 
bsweb

I appreciate your help.  I have installed a new template, although it shows up without any images or graphics. 

To be honest I'd really just like to add in my own header with logo into the CrystalX theme.  I wouldn't think it should be that hard.  In everything I've read, I need to make copies of the the themes, the images and the css so I don't alter the originals.  Then create my own theme and then add in my own image. Is that correct?  Or is there an easier way. 

I believe I will like this program if I can get past this initial setup.

Thanks!

--- (Edited on 10/24/2011 4:32 pm [GMT-0500] by bsweb) ---



Back to Top
Rate [
|
]
 
 
perlDreamer

To be honest I'd really just like to add in my own header with logo into the CrystalX theme.  I wouldn't think it should be that hard.  In everything I've read, I need to make copies of the the themes, the images and the css so I don't alter the originals.  Then create my own theme and then add in my own image. Is that correct?  Or is there an easier way. 

That's the right way to do it.  Making a copy is really to protect your work.

The CrystalX theme contains tempates, CSS and images that are part of the default WebGUI.  If we make bug fixes to those, and you've also made changes, then when you upgrade your files would be overwritten by the upgraded assets.

If you chose never to upgrade, then it wouldn't be an issue, but you also would get any other bug fix.  So, you're really better off making the copy.

--- (Edited on 10/25/2011 8:33 am [GMT-0700] by perlDreamer) ---



Back to Top
Rate [
|
]
 
 
bsweb

Is there an easy way to change the header with our own Logo and image?

--- (Edited on 10/25/2011 9:23 am [GMT-0500] by bsweb) ---



Back to Top
Rate [
|
]
 
 
bsweb

I have made a copy of the entire crystalx site.  I have tried to change the header with my own but it never shows.  I tried just changing the image to mine.  The image was gone but mine was not there.  I removed the entire header and tried adding my own but I still just get a page without a header.  Any thoughts on why mine would not be showing?

--- (Edited on 11/1/2011 4:43 pm [GMT-0500] by bsweb) ---



Back to Top
Rate [
|
]
 
 
bartjol

Hard to say with this information. If you can post a copy of your template on pastebin (http://webgui.pastebin.com) and post the link here or on IRC, people can have a look at it at their convenience

--- (Edited on 2-November-2011 10:16 [GMT+0100] by bartjol) ---



Back to Top
Rate [
|
]
 
 
bsweb

I have posted my template in pastebin.  My problem is none of the graphics show up on the page except the on titled intrawebhdr.jpg.  The background, tabs etc. do not show. The words show up fine but looks like text on a black page with no format.

I can paste the style.css if needed.

--- (Edited on 11/7/2011 1:05 pm [GMT-0600] by bsweb) ---



Back to Top
Rate [
|
]
 
 
     Goto page «Previous Page   1 2    Next Page»



© 2014 Plain Black Corporation | All Rights Reserved