plainblack.com
Username Password
search
Bookmark and Share

    

installing WebGUI on Ubuntu 10.04

User beeswax
Date 11/9/2010 6:22 pm
Views 6285
Rating -2    Rate [
|
]
Previous · Next
User Message
beeswax

I managed to "install" the WebGUI package on a Ubuntu 10.04 system using Synaptic.

But there is no " /data" directory.

Does this mean that I still have to download the WRE and proceed further from there? 

--- (Edited on 11/9/2010 6:22 pm [GMT-0600] by beeswax) ---



Back to Top
Rate [
|
]
 
 
preaction

No, there should be some sort of wg_addsite utility provided by the package, but I'll let someone else more familiar chime in.

Perhaps "man webgui" will give you something?

Perhaps /usr/share/doc/webgui contains something?

--- (Edited on 11/10/2010 10:35 am [GMT-0800] by perlDreamer) ---



Back to Top
Rate [
|
]
 
 
drift211

I am assuming that you installed the webgui package that is available from the synaptic package menu. In that case your webgui files will be spread all over the file system and there will be no /data directory.At the command line you can use

sudo find / -name webgui

to find all of the places where Webgui was installed. Most like you will want to goto the /etc/webgui for configuration and /usr/share/doc/webgui for setup information as the installation of the webgui for ubuntu is much different than using WRE.

I hope this helps.

--- (Edited on 11/27/2010 11:50 pm [GMT-0600] by drift211) ---



Back to Top
Rate [
|
]
 
 
rammer1

I am having similar difficulty to the initial poster. Complete newbie and tried  installing the WRE, but ran into problems at the point where you use the ". setenvironment.sh" command (error message). So scrapped that and installed WebGUI through the Synaptic package manager, which as has been said scatters the installation across the file system so that there's no /Data folder, and thus no Data/WebGUI/Sbin folder. The usr/Share/WebGUI/Sbin folder only contains the preload.perl script, so no "wreConsole" or whatever. And the http://wiki.webgui.org/installation-options page doesn't have anything for Ubuntu, and the install.txt file in the docs folder is a bit confusing (aren't apache, mysql and perl installed when you install WebGUI using Synaptic?).

Would really appreciate a newbie walkthrough for Ubuntu 10.x here. Should I try with the WRE again, or what am I missing? Been using the sudo prefixes etc.....

--- (Edited on 2/2/2011 2:50 pm [GMT-0600] by rammer1) ---



Back to Top
Rate [
|
]
 
 
    



© 2019 Plain Black Corporation | All Rights Reserved