plainblack.com
Username Password
search
Bookmark and Share

    

Build WRE on 64bit CentOS 5.5

User teox
Date 1/13/2011 8:50 am
Views 4894
Rating -5    Rate [
|
]
Previous · Next
User Message
teox

hi,

I'm having problems building wre on a 64bit CentOS:

/usr/lib/libexpat.so: could not read symbols: File in wrong format

Does anyone completed build on that OS succesfully?

ps: Right now I'm trying this prebuilt: wre-0.9.3-rhel-5-ia32.tar.gz, but still have problems on many PERL modules

--- (Edited on 1/13/2011 8:50 am [GMT-0600] by teox) ---



Back to Top
Rate [
|
]
 
 
preaction
The WRE 0.9.3 source will not easily compile on a 64-bit system. If you want, you can download the latest WRE source from our git repository at http://www.github.com/plainblack/wrebuild which will compile on your system.

To compile the WRE, you must run the getsource.sh and getperlmodules.sh before running build.sh. 

If you have any problems with the latest source, let us know and we'll try to help.

--- (Edited on 1/13/2011 11:40 am [GMT-0600] by Visitor) ---



Back to Top
Rate [
|
]
 
 
knowmad

With Doug's help, I've successfully compiled the WRE for 64-bit Ubuntu. He integrated my mods into the sources so you shouldn't have much trouble with it. See the wiki[1] for additional details (Ubuntu specific but should apply to CentOS).

 

William

[1] http://www.webgui.org/wiki/wre-building

----
Knowmad Technologies
http://www.knowmad.com

--- (Edited on 1/13/2011 8:15 pm [GMT-0500] by knowmad) ---



Back to Top
Rate [
|
]
 
 
teox

 

Thanks for replies, I've tried building with github WRE, but still:

/data/wre/prereqs/lib/perl5/5.10.1/x86_64-linux/CORE/libperl.a: could not read symbols: Bad value

 

 

 

--- (Edited on 1/14/2011 6:00 am [GMT-0600] by teox) ---



Back to Top
Rate [
|
]
 
 
milo

Hello,

thanks for the tips but I did have to change some settings for the github version (plainblack-wrebuild-v0.9.2-92.tar.gz). I'm using Gentoo.

Why is the version .92 instead of the current .93 version? Did I download the wrong one?

I attached my working install files.

Milo

--- (Edited on 18-January-2011 08:30 [GMT-0600] by milo) ---



Attached Files
Back to Top
Rate [
|
]
 
 
    



© 2019 Plain Black Corporation | All Rights Reserved